klink0v (klink0v) wrote,
klink0v
klink0v

Если вовремя не обновили Debian

Если зазевались и вовремя не обновили Debian 7 (Wheezy), то при очередной попытке сделать "apt-get upgrade" он может выматериться:

W: Произошла ошибка при проверке подписи. Репозиторий не обновлён и будут использованы предыдущие индексные файлы. Ошибка GPG: ftp://myserver.com wheezy Release: Следующие подписи неверные: BADSIG 8B48AD6246925553 Debian Archive Automatic Signing Key (7.0/wheezy) <ftpmaster@debian.org>

В такой ситуации совсем не нужно мудрить с gpg и apt-key. Всё намного проще. Достаточно убрать из настроек apt-а security-репозитории, произвести обновление ("apt-get update && apt-get upgrade"), после чего вернуть security-репозиторий на место и повторить ту же процедуру заново. Всё.

А обновиться надо. Тем более, что относильно недавно обнаружили серьёзную уязвимость в glibc. Версии пакетов, которые уже не подвержены эксплойтам:

Ubuntu 12.04 LTS: 2.15-0ubuntu10.10
Ubuntu 10.04 LTS: 2.11.1-0ubuntu7.20
Debian 7 LTS: 2.13-38+deb7u7

Если у вас более тухлые, лучше это побыстрее поправить.

Tags: debian, linux, администрирование
Subscribe
  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 0 comments