January 7th, 2021

Cat-light

Не клеится у меня видеонаблюдение дома...

Недолго я радовался смонтированной дома у родителей системе видеонаблюдения. Меньше года она исправно проработала. А потом начались какие-то чудеса. Софт-видеорегистратор (Blue Iris) стал постоянно рапортовать о потере сигнал с камер. Шосукахарактерно, "терять" камеры он начал ровно тогда, когда в кадре начинается какое-то движение.

Перепробовал уже много всего.


  1. Подключил сервер напрямую к тому же свитчу, что и камеры, минуя промежуточные маршрутизаторы.

  2. Попробовал заменить свитч на другой, неуправляемый.

  3. Перенёс видеозаписывающий софт с ноутбука на более мощный "взрослый" компьютер с 4-ядрёным CPU внутри.

Ничего не помогло. По ходу дела, эта ерунда началась после какого-то очередного обновления софта. Но какого именно, вспомнить уже не могу. Теперь вот думаю, то ли продлить лицензию и обновить софт. То ли наоборот, попробовать поставить ту версию потухлее, которую устанавливал в самом начале. Хрень какая-то. И непонятно как диагностировать / отлаживать.

"До кучи" служба Blue Iris, будучи запущенной в KVM-виртуалке, начала провоцировать BSOD на форточках. Что-то там про нарушение защиты драйвера. Вылечилось добавлением параметра "ignore_msrs=1" модулю ядра "kvm". Пока не гуглил что такое этот msrs и почему его надо игнорировать. Пишу чтобы потом есличо, самому не забыть.

То ли пробовать какую-нибудь другую софтину для видеонаблюдения, то ли продолжать мудохаться с этой. Хрен его знает, товарищ прапорщик...